Menu:

Sponsor

Discover Master of Alchemy, our first iPad/iPhone and iPod touch game!

Follow Me

 

Forum's topics

Latest Files

Archives

Top Rated

Categories

Photo Gallery


Alessandro Crugnola on August 30, 2004 in flash

Strange issue with Flash Updater 7.2

I got this very strange behavior (let me say BUG) with the new flash updated version 7.2, and which drove me crazy for a while!

Create a new document, settings set to flash player 7 and AS2.
Create in the document a movieclip with exporting settings, export for ActionScript, and give the name "mc". Delete the movieclip from the timeline.
try the code:

depth = _root.getNextHighestDepth() 
trace(depth);
_root.attachMovie('mc','mc',depth)
mc.onRelease = function(){
this.removeMovieClip();
}


you will get a "0" in the trace output and once click on the movieclip, this will disappear.

NOW.
Drag a component on the stage, for example the tree component, and then delete it from the timeline. This is just in order to have it into the library.
Test the movie again.

I get in the trace output the value of "1048576" and the movieclip does not disappear now!

incredible!

 

 

Bookmark and Share

 

Tags: bug , flash updater 

 



Post a comment

(If you haven't left a comment here before, you may need to be approved by the site owner before your comment will appear. Until then, it won't appear on the entry. Thanks for waiting.)


Type the characters you see in the picture above.





 

TrackBacks

TrackBack URL for this entry: http://www.sephiroth.it/cgi-bin/mt/mt-tb.cgi/158